Trailer Lights Problem

All about towing and tow vehicles

Trailer Lights Problem

Postby djohnsonnv » Tue May 23, 2017 9:44 am

The other week I set up my Kia Soul for light towing. I purchased a Draw Tight Class I hitch and a Curt T-Connector Wiring Harness from E-Trailer. The set up is pretty straight forward. Plug in a t-connector in each taillight and ground the system to the vehicle with a self tapping screw provided. Install went well but when I plugged in the trailer I ran into a problem.

The trailer lights will only run if the vehicle's taillights are unplugged. I contacted etrailer and did some research online. NOt too much on the subject since the Soul isn't rated for towing in the US.

My theory is that it isn't grounding well and/or the load is too high to run both the vehicle lights and the trailer lights. My question to the forum is would stripping the paint between the grounding wire and frame help? Does this theory make since? Has anyone ran into a similar issue especially with the type of wire set up?
User avatar
djohnsonnv
Teardrop Inspector
 
Posts: 16
Joined: Tue Oct 11, 2016 3:28 pm
Location: Las Vegas, Nevada

Re: Trailer Lights Problem

Postby friz » Tue May 23, 2017 10:25 am

I would contact Curt. Your harness should be vehicle specific. I noticed that they offer two models. One if you have led tail lights on your car and a different one for conventional tail lights.
The "Sin Bin"
150133
User avatar
friz
The 300 Club
 
Posts: 323
Images: 2
Joined: Mon Jan 03, 2011 10:01 pm

Re: Trailer Lights Problem

Postby tony.latham » Tue May 23, 2017 10:56 am

Friz has a good point so that may be it.

The preponderance of trailer light problems stems from the ground. Yes, I'd try scraping off the paint and adding a coat of dielectric grease to prevent corrosion.

Tony
Image
User avatar
tony.latham
Silver Donating Member
 
Posts: 2276
Images: 17
Joined: Mon Jul 08, 2013 4:03 pm
Location: Middle of Idaho on the edge of nowhere
Top

Re: Trailer Lights Problem

Postby Norm » Tue May 23, 2017 8:27 pm

Installed plug in connector on my 2011 Soul. Mine feeds load directly from battery. I have no problems so far.


Sent from my iPad using Tapatalk
User avatar
Norm
Teardrop Master
 
Posts: 149
Images: 10
Joined: Mon Jun 14, 2004 9:04 pm
Location: Cornwall, ON. Canada
Top

Re: Trailer Lights Problem

Postby Dale M. » Wed May 24, 2017 7:51 am

Paint should always be removed under any ground connection... And yes a dab of dielectric grease (light bulb grease) to keep moisture and oxygen out of "connection" is desirable...

Dale
Lives his life vicariously through his own self.

Any statement made by me are strictly my own opinion.
You are free to ignore anything I say if you do not agree.

Image
User avatar
Dale M.
2000 Club
2000 Club
 
Posts: 2647
Images: 18
Joined: Thu Jun 09, 2005 8:50 pm
Location: Just a tiny bit west of Yosemite National Park
Top


Return to Towing and Tow Vehicles

Who is online

Users browsing this forum: No registered users and 0 guests